
Partie 01 – Introduction à Android

PROGRAMMATION 
ANDROID

Ana ROXIN



Que vous débutiez en développement ou que vous soyez déjà un développeur Java aguerri, Android est une 
excellente opportunité pour appréhender le développement d’applications mobiles ambitieuses. Ce premier cours 
vous permettra de vous familiariser avec la plate-forme Android et l’environnement de développement Eclipse.

Plan du cours
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Fichiers source
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� Sur ufrsciencestech.u-bourgogne.fr

� Répertoire UE5/AR

� Cours

� TD: énoncé + fichiers source
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Installation
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� Connexion sous Linux

� ADT Bundle pour Linux 64-bit - adt-bundle-linux-x86_64.zip

� A télécharger, puis à extraire sur le bureau

� Ouvrir Eclispe

� Dossier_ADT/eclipse/eclipse.exe

� Lancer le Android SDK Manager

� Vérifier les mises à jour du SDK

� Versions obligatoires: 1.5, 1.6, 2.1, 4.0 à 4.1
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Points clés de la plate-forme Android

Semestre Printemps 2013Ana ROXIN | Cours LPSIL | Programmation Android

• Intègre toutes les dernières technologies de téléphonie mobile : écran 
tactile, accéléromètre, GPS, appareil photo numérique etc. 

Innovante

• Pas d’achat de matériel spécifique;
• Pas de connaissance d’un langage peu utilisé ou spécifique : Java;

Accessible

• Fournie sous licence open source
• Permet de consulter les sources et d’effectuer des modifications.

Ouverte
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La plate-forme Android
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� Android = système d’exploitation pour mobiles open source développé par 
la société Google

� Juin 2007 – création de OHA (Open Handset Alliance)

� Fabricants de téléphones: HTC, Sony Ericsson, Samsung ou Motorola

� Opérateurs de téléphonie: Sprint, T-Mobile ou NTT DoCoMo

� Société Internet: Google, eBay

� Constructeurs de puces électroniques: Intel, nVidia

� Autres acteurs: Garmin

� Open Handset Alliance et Android sont des marques déposées.

Plus de renseignements

� site de l’OHA: http://www.openhandsetalliance.com/
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Les membres de l’OHA
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Quelques offres des constructeurs
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Android  = Google Phone

HTC
Desire HD

Huawei
U8230

Google
Nexus 7

Acer
Stream

Motorola
Razr HD

Sony
Xperia X10
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Les versions de la plate-forme (1)
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Version Date Nom Remarques

Android 1.0 09/2008 Android Market, sites Web en (X)HTML, appareil photo, dossiers d’applications, synchro Gmail, etc.

Android 1.1 02/2009 Petit Four Mise en ligne pour le HTC Dream

Android 1.5 04/2009 Cupcake Basée sur le noyau Linux 2.6.27, support pour les claviers virtuels, les widgets, copier/coller, etc.

Android 1.6 09/2009 Donut Basée sur le noyau 2.6.29, màj de la recherche et de la recherche vocale, interface Android Market améliorée

Android 2.0 10/2009 Eclair Vitesse hardware optimisée; support de plus de taille d’écran et résolutions, réorganisation de l’UI, nouvelle 
interface du navigateur et support de l’HTML5

Android 2.2 05/2010 FroYo Basée sur le noyau 2.6.32, optimisations générales de la vitesse, de la mémoire et des performances de l’OS

Android 2.3 12/2010 Gingerbread Basée sur le noyau 2.6.35, màj interface utilisateur, support de nouveaux capteurs (gyroscope et baromètre), 
support du développement en code natif amélioré, etc.

Android 3.0 02/2011 Honeycomb Basée sur le noyau 2.6.36 et réservée aux tablettes tactiles

Android 4.0.1 10/2011 Ice Cream
Sandwich

Basée sur le noyau 3.0.1
Boutons virtuels intégrés à l’interface, création facilitée des dossiers, amélioration du copier/coller, etc.

Android 4.1.1 07/2012 Jelly Bean Basée sur le noyau Linux 3.0.31
Amélioration des fonctionnalités (recherche vocale, appareil photo, usb audio, Google Chrome, etc.)
Interface utilisateur plus fluide (synchronisation Vsync, triple buffering)

Android 4.2.1 11/2012 Amélioration de la stabilité et des performances
Correction du bug du mois de décembre 2012
Bluetooth: Résolution de problèmes, ajout de GamePads et Joystick Bluetooth

Android 5.0 Key Lime Pie
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Les versions de la plate-forme (2)
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Plus de renseignements

� http://developer.android.com/about/dashboards/index.html
� http://fr.wikipedia.org/wiki/Historique_des_versions_d'Android
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L’architecture
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La licence
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� La licence principale du projet Android est la licence Apache 2.0.

� Autorise la modification et la distribution du code sous forme libre ou non;

� Permet, comme toute licence vraiment libre, d’en faire un usage commercial. 

� Oblige le maintien du copyright lors de toute modification (et également du 
texte de la licence elle-même).

� D’autres parties du projet peuvent être sujettes à d’autres types de licences

� Parties logicielles proches du noyau Linux qui sont concernées par la licence GPL

Plus de renseignements

� http://www.gnu.org/licenses/license-list.html
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Pratique: découverte des tablettes (1)
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� Connexion au réseau WiFi: IEMInfo

� Avec vos login et mdp pour les salles de TP

� Pour connaitre les caractéristiques de la tablette 
Android Info System



Pratique: découverte des tablettes (2)

Semestre Printemps 2013Ana ROXIN | Cours LPSIL | Programmation Android

15

� Identification avec un compte google

� Gestion du compte Google: Paramètres système > Comptes et synchro



Pratique: découverte des tablettes (3)
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� Savoir qui est connecté à votre compte Gmail



Pratique: découverte des tablettes (4)
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� Deux solutions s’offrent à nous:

� Si l’appareil est neuf ou si l’on vient d’installer une nouvelle ROM (d’origine ou 
alternative), il suffit de ne pas saisir l’identifiant Gmail, et de ne pas le créer, 
lorsque celui-ci vous est demandé.

� Si le compte est déjà actif sur votre smartphone, il s’agit de le supprimer. Il faut 
également le supprimer de toutes les applications utilisant ce compte.

� Rendez-vous dans Paramètres > Applications > Gérer les applications. 
Sélectionnez Gmail. 

� Là, cliquez sur Effacer les données. Il faudra répéter ces opérations pour les autres 
applications recourant au fameux compte : Gtalk, Google Documents, Google Maps, 
Contacts, Galerie, etc.

� À ce stade, un message « Warning » devrait apparaître dans la zone de 
notification. 

� Pour le faire disparaître, il est nécessaire d’enregistrer un compte Google valide !



Pratique: découverte des tablettes (5)
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Pratique: découverte des tablettes (6)
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Pratique: découverte des tablettes (7)
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� CyanogenMod : ROM alternative

� L’utilisation de ROM alternatives, 
comme CyanogenMod, permet de 
gérer les droits pour chaque 
application. 

� CyanogenMod agit en quelque sorte 
comme un pare-feu (firewall). Même si 
une application veut un droit, on peut 
l’empêcher de l’avoir ; elle restera tout 
de même opérationnelle.



Pratique: découverte des tablettes (8)
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� L’application Google Play installée sur le 
smartphone permet dans ses options 
d’appliquer un filtrage sur le contenu 
(Paramètres > Filtrage des contenus). 

� Aucun lien avec la sécurité, 

� Permet de créer un filtre des applications 
qui seront proposées au téléchargement en 
fonction des critères définis

� Ce paramètre est à vérifier si certaines 
applications refusent de s’afficher dans le 
module de recherche.



Pratique: découverte des tablettes (9)
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� http://fr.appbrain.com

� Cette application peut 
avantageusement remplacer 
Google Play. 

� Elle se décompose en deux 
parties : 

� un site Internet

� une application sur l’appareil.

� http://yaam.mobi

� http://f-droid.org



Pratique: découverte des applications 
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� L’antivirus avast! Free Mobile Security

� Divers
� Timeriffic, pour minuter les périodes de veille ou mode Avion

� eBuddy Messenger pour tchatter

� Evernote : un bloc-notes sur le cloud

� Pour l’administrateur système et réseau
� Hacker’s Keyboard: clavier avec les touches Ctrl et Alt

� ConnectBot : se connecter à distance via SSH

� TeamViewer : bureau à distance

� Fing - Network Tools : utilitaire réseau



Semestre Printemps 2013Ana ROXIN | Cours LPSIL | Programmation Android



Le SDK
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� Google fournit, en plus du système d’exploitation, un kit de développement 
comprenant: 

� des API (interfaces de programmation) ;

� des exemples de code ;

� de la documentation ;

� des outils – parmi lesquels un émulateur – permettant de couvrir quasiment 
toutes les étapes du cycle de développement d’une application.

� Le SDK Android est disponible gratuitement sur le site de Google.

Plus de renseignements

� http://developer.android.com
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La documentation
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� La documentation du SDK Android est scindée en deux parties bien 
distinctes :

� Le guide du développeur: 

� Disponible en HTML 

� Dans le répertoire /docs/guide/index.html.

� La documentation des API 

� Au format javadoc – générée automatiquement à partir des commentaires du code 
source formatés avec une syntaxe précise

� Dans le répertoire /docs/reference/packages.html.
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Les exemples d’applications
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� Le kit de développement est accompagné de quelques exemples illustrant 
les possibilités du SDK Android. 

� dans le répertoire platforms\android-2.0\samples

� Parmi ces exemples, on peut citer:

� un jeu du serpent (répertoire Snake) ;

� un projet qui couvre l’utilisation de plusieurs pans de l’API Android comme les 
alarmes, les notifications, les menus, etc. (répertoire APIDemos) ;

� une application pour sauvegarder des notes (répertoire NotePad).
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Les outils de développement du SDK
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� Le SDK est livré avec un certain nombre d’outils couvrant différents aspects 
du cycle de développement d’une application Android. 

� Dans le répertoire tools du SDK

� Parmi ces programmes, on peut citer:

� DDMS – outil de débogage puissant ;

� mksdcard – outil de création de cartes mémoire logicielles utilisables avec 
l’émulateur ;

� sqlite3 – outil pour accéder aux fichiers de données au format SQLite.

� ADT (Android Development Tools Plugin) – outil intégrable à Eclipse, proposant 
des interfaces et des assistants pour la création et le débogage d’applications.

28



Semestre Printemps 2013Ana ROXIN | Cours LPSIL | Programmation Android



Quelques liens utiles…
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� Récupérer les sources d’Android

� http://source.android.com/

� Sites d’informations sur Android:

� Site officiel d’Android: 

� http://www.android.com/

� Site pour les développeurs Android: 

� http://developer.android.com/index.html

� Sites pour suivre l’actualité Android en français:

� http://www.pointgphone.com/

� http://android-france.fr/

� Site pour rechercher des applications Android:

� http://www.androlib.com/
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Les outils indispensables
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� Eclipse

� http://www.eclipse.org/

� Eclispe IDE for Java EE Developers (la plus complète)

� SDK Android + plugin ADT Eclispe

� http://developer.android.com/sdk/index.html

� Java Runtime Environment (JRE)

� http://www.oracle.com/technetwork/java/javase/downloads/jre7-downloads-
1880261.html
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Ecran d’accueil d’Eclipse Java
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Android SDK Manager
Android Virtual Device Manager
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Lien avec le SDK Android
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� Menu Window > Lien Preferences
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Créer un émulateur
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� Ouvrir l’AVD (Android Virtual Device Manager)

� Cliquer sur New, puis remplir les champs:

� AVD Name: LpsilAndroid

� Device 3,2’’ HVGA slider

� Target: si possible 1.5, sinon dernière version du SDK

� Cliquer sur Start…

� Lancement de l’émulateur:

� Invite de commandes

� Aller dans le dossier d’installation du SDK, puis dans le
répertoire tools

� emulator.exe –avd LpsilAndroid
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Découverte de l’émulateur
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Touche Description

Touche 9 pavé
numérique

Passer en mode 
paysage / repasser 
en mode portrait.

Touche + Augmente le volume

Touche – Diminue le volume

F8
Activer/désactiver le 
réseau cellulaire.

Alt + Entrée
Activer/désactiver le 
mode plein écran.

F6
Activer/désactiver le 
trackball.
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Créer un nouveau projet Android (1)

Semestre Printemps 2013Ana ROXIN | Cours LPSIL | Programmation Android

37



Créer un nouveau projet Android (2)
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Créer un nouveau projet Android (3)
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Créer un nouveau projet Android (4)

Semestre Printemps 2013Ana ROXIN | Cours LPSIL | Programmation Android

40



Créer un nouveau projet Android (5)
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Créer un nouveau projet Android (6)
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Aperçu du premier projet (1)
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Aperçu du premier projet (2)
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Aperçu du premier projet (3)
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Lancement de l’application dans 
l’émulateur
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Etude de la structure du projet (1)
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Elément considéré Description

Répertoire src Le répertoire de l’ensemble des sources du projet. C’est dans ce répertoire que vous allez 
ajouter et modifier le code source de l’application.

Répertoire libs Contient les bibliothèques tierces qui serviront à votre application.

Répertoire res Contient toutes les ressources telles que les images, les dispositions de l’interface graphique, 
etc. nécessaires à l’application. Ces ressources seront accessibles grâce à la classe R décrite 
plus loin.

Répertoire gen Contient l’ensemble des fichiers générés par ADT afin d’assister le développeur. Si vous 
supprimez un fichier dans ce répertoire, ADT s’empressera aussitôt de le régénérer. 
Attention, si le projet contient des erreurs ne permettant pas sa compilation, ADT ne générera 
aucun fichier. Par conséquent, si vous ne trouvez pas la bonne version de fichier ou si le fichier 
n’est pas généré automatiquement, vérifiez bien que l’ensemble du projet compile.

Répertoire assets Contient toutes les ressources brutes (raw bytes) ne nécessitant aucun traitement par ADT ou 
Android. À la différence des ressources placées dans le répertoire res, les ressources brutes 
seront accessibles grâce à un flux de données et non grâce à la classe R décrite plus loin.

Fichier AndroidManifest.xml Le fichier XML décrivant l’application et ses composants – activités, services, etc.

Fichier project.properties Fichier de propriétés utilisé pour la compilation.
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Etude de la structure du projet (2)
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� Le répertoire res est composé de différents sous-répertoires dont les 
suivants :

� res/drawable contient les ressources de type image (PNG, JPEG et GIF) ;

� res/layout contient les descriptions des interfaces utilisateur ;

� res/menu contient la description des menus ;

� res/values contient les chaînes de caractères, les dimensions, etc. ;

� Dans les versions précédentes, il y avait aussi:

� res/xml contenait des fichiers XML supplémentaires (préférences, etc.) ;

� res/raw contenait des ressources autres que celles décrites ci-dessus qui seront 
empaquetées sans aucun traitement.
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Etude de la structure du projet (3)
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Etude de la structure du projet (4)
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Etude de la structure du projet (5)
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Anciennes versions…
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L’application Bonjour modifiée
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Remarques sur la compilation
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� Méthode de compilation – Menu Projet > case Build Automatically cochée

� Les projets sont compilés automatiquement dès qu’on enregistre un fichier source.

� Seulement si pas d’erreurs dans le code

� L’application exécutée est la dernière version compilée

� Le résultat d’une compilation sera placé selon 
l’arborescence suivante :
� bin/classes.dex : représente l’exécutable compilé pour la 

machine virtuelle Dalvik (résultat de la compilation du code 
source);

� bin/res : contient les ressources de votre application;

� bin/Bonjour.apk : il s’agit de votre application compilée et empaquetée pour être 
déployée dans le système Android. 
Ce fichier contient le fichier .dex, les ressources compilées et non compilées (celles 
contenues dans le répertoire /raw) et enfin le fichier de configuration de l’application.
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Fichier AndroidManifest.xml
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Librairies
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Dalvik Debug Monitor Service
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Ecran d’accueil d’Eclipse DDMS
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Le LogCat – vue d’ensemble
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Le LogCat – utilisation dans le cadre d’un 
projet (1)
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Le LogCat – utilisation dans le cadre d’un 
projet (2)
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Ajouter une vue à une perspective
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� Menu Window > lien Show View > Other…

� Android > LogCat
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Passer en perspective debug
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� Menu Window > Lien Open Perspective > Debug



Définir un point d’arrêt
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Surveiller les valeurs des variables
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Ajouter des espions (expressions)
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� Menu Window > Show View > Other…

� Debug > Expressions

� Onglet « Expressions » > Lien Add new expression… > « i »



Etat des variables
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Accès au terminal mobile avec Eclipse
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Faire une capture d’écran

Semestre Printemps 2013Ana ROXIN | Cours LPSIL | Programmation Android

71



Paramétrer le terminal mobile
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� Brancher la tablette avec le câble USB fourni

� Sur la tablette, aller dans Paramètres > Applications

� cocher la case Sources inconnues

� Menu Développement > cocher la case Débogage USB
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Aide dynamique
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Javadoc
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� Menu Window > Show View > Javadoc



Onglet Problems

Semestre Printemps 2013Ana ROXIN | Cours LPSIL | Programmation Android

76



En cas d’erreur…
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Auto-complétion
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� Ctrl + espace



Auto-indenter
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� Ctrl + I



Commentaires
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� //

� /* code commenté */

� Raccourci clavier: sélectionner code puis Ctrl + Shift + C

� Une 2e fois, cela supprime le commentaire



Liste des raccourcis clavier
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� Ctrl  + Shift + L

� 1e fois: affichage de l’ensemble des raccourcis

� 2e fois: page des préférences


