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I - PRESENTATION OPENOFFICE.ORG WRITER

 I.1 - Généralités

OpenOffice.org  Writer  est  le  logiciel  de  traitement  de  texte  inclut  dans  la  suite 

bureautique OpenOffice.org. Le logiciel se présente comme une solution alternative à Word de 

la suite Office publiée par Microsoft avec quelques avantages quant à la licence et l’utilisation. 

En effet, OpenOffice.org est sous la licence GPL (  General Public Licence  - Licence Publique 

Générale)  ce  qui  permet  la  distribution  et  la  modification  du  logiciel  de  façon  libre  par 

quiconque.

La compatibilité entre Word et Writer est presque totale. Mis à part quelques "bugs" 

de mise en  forme, il n'y aucune faille majeure dans la conversion de documents Microsoft 

Office. 

 I.2 - Interfaces

L'interface  graphique  est  très  semblable  à  celle  de  Microsoft  Word  mis  à  part 

quelques différences quant à la disposition et au contenu des barres d'outils. Contrairement à 

Microsoft Word, OpenOffice.org Writer n'a pas une panoplie de barres d'outils. Writer n'a que 

trois barres d'outils qui sont, cependant, hautement configurables :

•  la barre de fonctions : Elle se situe sous la barre de menus. Quoique très semblable à 

celle  de  Microsoft  Word,  on  y  retrouve  un  menu  déroulant  qui  mémorise  les  derniers 

fichiers ouverts durant la session; très pratique lorsqu'on veut accéder de nouveau à un 

fichier récemment ouvert. 

•  la  barre d'objets :  Elle est située sous la barre de fonctions. C'est en comprenant le 

principe de la barre d'objets qu'on comprend également pourquoi il y a si peu de barres 

d'outils dans Writer. Cette barre est dynamique, c'est- à- dire qu'elle change selon le type 

d'objet que l'on sélectionne. Si l'on sélectionne un texte, les options standard de mise on 

forme  s'y  afficheront;  c'est  d'ailleurs  ces  options  qui,  par  défaut,  composent  la  barre 

d’objets. Si, par ailleurs, l’on sélectionne un dessin, les options de modification de dessin 

s'y retrouveront, de même pour un tableau et tous le autres types d'objets.

• la barre d'instruments : Cette barre, aussi appelée barre latérale puisqu'elle se trouve à 

gauche de la fenêtre Writer. Elle résume la plupart des fonctions les plus populaires d'un 

logiciel  de traitement  de texte  (insertion,  dessin,  outils  de création de formulaires).  En 

cliquant sur une icône en gardant le bouton gauche enfoncé, on a accès à plusieurs autres 
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fonctions en plus de celles qui sont directement sur la barre.

La barre des menus de Writer est également différente de celle Word. Tous les 

menus de Word y sont à l'exception du menu Tableau qui, selon Writer, n'est pas nécessaire. 

Cependant,  le  contenu  des menus Writer  diffère légèrement  du contenu des menus Word 

(voir III pour les équivalences).

L'interface de OpenOffice.org se caractérise par deux grandes nouveautés :

le Styliste et le Navigateur  qui se présentent sous forme de fenêtres volante à la demande.

• le Styliste. Il est utilisé pour changer le style du texte en quelques clics;

•  le  Navigateur  est  un outil  est  particulièrement  utile  pour  les  documents  longs  qui 

comportent  beaucoup de chapitres, de sections, d'images, etc.

Si ces fenêtres flottantes ne sont pas visibles, vous pouvez les afficher en cliquant sur l'icône 

du Navigateur et celle du Styliste  que vous trouverez dans la barre de Fonctions.
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 I.3 - Efficacité et performance

OpenOffice.org semble être en meilleure communication avec l'utilisateur. Avec la 

barre  d'objets  et  les  menus  dynamiques,  le  logiciel  paraît  mieux  connaître  les  désirs  de 

l'utilisateur. Toutes les options dans les menus ne sont pas disponibles en tous temps. Elles 

varient  autant  que  la  barre  d'objets.  Au  début,  cela  peut  être  fatiguant  puisqu'on  a 

l'impression que Writer nous offre moins de possibilités que Word, qu'il est moins complet. 

Les paramètres par défaut dans OpenOffice diffèrent de ceux dans Microsoft Office.
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 I.4 - Aide et assistance

L'aide dans toute la suite OpenOffice.org est construite en style hypertextes.

Lorsqu'on cherche comment  faire un certain  dessin  ou comment  insérer  un certain  objet, 

l'aide est la meilleure ressource que l'on puisse avoir. Or, l'aide fournie avec OpenOffice est 

tout  aussi  efficace que celle  incluse  avec Microsoft  Office  Word. L'aide est  sous le format 

Microsoft  Windows  avec  un  onglet  Contenu  (  Sommaire),  un  onglet  Index,  un  onglet 

Recherche ( Aide intuitive), et un onglet supplémentaire très pratique: les Signets. 

II - QUELQUES MANIPULATIONS  COURANTES

 II.1 - Taper et formater un document Texte OpenOffice.org

Au  lancement  de Writer,  la  plage  de  document  dans  laquelle  vous  tapez  votre  texte  est 

délimitée par une fine ligne grise, c'est un guide des limites du texte. Ces marges peuvent 

être modifiées de cette façon :

1. cliquez sur l'icône Style de Page   dans le Styliste,

2. sélectionnez le style Standard et faites un clic droit pour afficher le menu contextuel,

3. Choisissez Modifier... dans ce menu pour afficher la fenêtre de dialogue Style de Page

4. réglez les marges sous l'onglet Page de cette fenêtre.

Attention : En modifiant le style de page par défaut,  cela signifie  que chaque fois que vous ouvrirez un nouveau  

document, votre page aura ces nouveaux paramètres de marge. Si vous désirez que ces changements ne s'appliquent  

qu'au document actif, il est préférable de créer un nouveau style. Répétez la procédure décrite ci-dessus, mais au n°  

3, sélectionnez Nouveau... dans le menu contextuel. Un style complètement nouveau sera créé et les nouvelles marges  

ne s'appliqueront que lorsque vous appliquerez le style à la page.

Le clignotement  du curseur  vous indique où le texte  que vous allez taper va être inséré. 

Essayez de taper une phrase comme : Hello le Monde ! (c'est un classique n'est-ce pas ?)

Elle sera écrite avec la police et le style par défaut. Habituellement, lorsque vous saisissez un 

texte dans votre document avant un autre texte, la section déjà présente se déplacera vers la 

droite de la nouvelle insertion. Cependant, cette façon de faire peut ne pas être très utile 

dans certaines situations. Par exemple, lorsque vous voulez écrire par dessus certains mots 

sans  avoir  à  utiliser  la  touche  'effacer'  de  votre  clavier,  vous  pouvez  passer  en  mode 
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Refrappe en faisant un clic gauche sur la case INS dans la barre d'état. Les initiales dans la 

barre vont se transformer en RFP. (La touche 'inser' de votre clavier aura le même effet). 

Maintenant, tout ce que vous allez taper va s'inscrire par dessus ce que vous aviez déjà saisi 

dans votre document. Pour revenir au mode 'insertion', refaite simplement un clic gauche au 

même endroit dans la barre d'État. Dans chaque nouveau document, le curseur est localisé 

en haut dans le coin gauche de votre plage d'écriture. Si vous désirez commencer à écrire à 

un  autre  endroit  et  que vous  n'avez pas encore de texte  inséré,  trois  options  s'offrent  à 

vous :

• Vous pouvez insérer  plein  de marques  de paragraphes  inutiles  en appuyant  sur  la 

touche Entrée de votre clavier,  pour atteindre le point  où vous voulez commencer. 

C'est une solution peu élégante et non professionnelle, à utiliser uniquement si vous 

n'avez vraiment aucune expérience,

• Vous pouvez cliquer sur l'icône Curseur Direct   dans la barre d'Outils et activer 

cette fonction. Cette icône est une touche à bascule, ce qui signifie que cette fonction 

sera active jusqu'à ce que vous recliquiez dessus. Déplacez le curseur de votre souris 

vers un espace vide de votre document, vous verrez apparaître un triangle bleu sur la 

gauche. Un clic  de plus et le curseur  se positionnera exactement  sur la ligne et la 

position (gauche, centrée, droite) qu'indique le triangle bleu.

• Enfin, vous pouvez également insérer un cadre de texte à partir de la barre des Menus 

en choisissant : Insertion – Cadre. Vous le positionnerez et l'ancrerez où bon vous 

semble dans votre document. 

Bien sûr, un document composé seulement de deux mots n'est pas très utile.  Tapez donc 

deux ou trois lignes en n'appuyant sur la touche ENTREE que lorsque vous êtes à la fin d'un 

paragraphe.  Répétez cette  action pour créer un second paragraphe. Maintenant,  pour une 

raison ou une autre, vous souhaitez peut-être sélectionner une partie du texte. Une sélection 

est l'action de mettre le texte en surbrillance pour ensuite appliquer, à cette portion de texte 

seulement, des actions particulières. Habituellement, le texte sélectionné apparaît en vidéo 

inverse. Vous pouvez effectuer cette sélection de différentes façons :

• sélectionner un simple mot en cliquant deux fois avec la touche gauche de la souris 

dessus,

• sélectionner une ligne en cliquant trois fois quelque part dans la ligne,

• sélectionner  plusieurs  lignes  en cliquant  une  fois  au début  du texte  et  en glissant 

jusqu'à l'endroit désiré sans relâcher le bouton de la souris,
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• sélectionner  plusieurs parties  non adjacentes  de texte  en sélectionnant  la première 

section puis  en cliquant  sur les autres sections tout  en maintenant  la touche CTRL 

enfoncée,

• sélectionner  tout  le  texte  en  appuyant  sur  les  touches  CTRL+A de  votre  clavier 

(appuyez et maintenez sur CTRL et pressez la touche A).

Vous  pouvez  vous  entraîner  à  pratiquer  les  actions  les  plus  usuelles  sur  votre  texte 

sélectionné : copier, couper, supprimer, et formater. Si vous désirez copier dans le presse 

papier une partie de texte sélectionnée, appuyez sur  CTRL+C. Si vous désirez couper cette 

partie, appuyez sur CTRL+X. Vous pouvez coller le texte ailleurs en appuyant sur CTRL+V. 

Les raccourcis claviers sont standard et vous pouvez également trouver ces fonctions dans la 

barre de fonctions, sous forme d'icônes.

Pour  effacer  un  texte  sélectionné  on  procède  de  la  même  manière  que  dans  beaucoup 

d'autres  suites  bureautiques  :  appuyez  simplement  sur  la  touche  'supprimer',  la  barre 

d'espacement, ou écrivez un autre texte pour écrire par dessus la sélection. Par contre, la 

mise en forme se fait légèrement différemment sous OOo que ce que vous avez pu rencontrer 

jusqu'à maintenant dans les autres suites. En fait, il y a deux manières de formater du texte 

dans Writer.

1. Utiliser les outils mis à disposition dans la barre de Fonctions ou dans le menu Format,

2. utiliser le Styliste (voir la prochaine section)

Pour le moment, nous n'allons commenter que le point n° 1.

Vous  pouvez commencer  par  modifier  un  texte  sélectionné  en changeant  les  attributs  de 

style.  Après  avoir  sélectionné  ce que  vous  désirez  changer,  cliquez  sur  l'une  des  icônes 

d'attribut   de la barre de Fonctions. Elles transforment le texte sélectionné (de 

gauche à droite) en Gras, Italique et Souligné. Il est  aussi possible d'utiliser les raccourcis 

claviers pour arriver au même résultat.

• CTRL+G pour Gras

• CTRL+I pour Italique

• CTRL+U pour Souligné.

Une  sélection  plus  fine  des  attributs  de  texte  peut  se  faire  en  sélectionnant  Format  – 

Caractère ou Format – Paragraphe... à partir de la Barre des Menus, suivant la partie de 

texte que vous désirez modifier. 
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Dans OOo, vous avez la possibilité de modifier à la fois l'alignement et la couleur du premier 

plan ou de l'arrière plan du texte.

1. Cliquez sur les  icônes d'alignement  dans la barre de Fonctions pour 

modifier l'alignement du texte (aligné à gauche, centré, aligné à droite ou justifié)

2. Cliquez  en  maintenant  votre  doigt  quelques  secondes  sur  l'une  des  icône  de 

Couleurs, une  palette  de couleur  va s'afficher  pour  que vous puissiez  sélectionner 

celle que vous désirez.

Astuce : la palette de couleur peut être transformée en palette flottante qui restera ouverte jusqu'à ce que vous la  

fermiez en appuyant sur le petit bouton en forme de croix dans le coin supérieur. Pour afficher la palette flottante,  

recommencez l'étape 2 de la procédure listée plus haut, cliquez et maintenez votre doigt jusqu'à ce que la palette  

apparaisse,  puis  déplacez  la  souris  n'importe  où  dans  la  fenêtre  et  enfin,  relâchez  le  bouton  de  la  souris.  Ce  

comportement est commun à d'autres fonctions de la barre d'Outils.

Si vous avez exécuté toutes les procédures que nous vous avons montré jusqu'à maintenant, 

vous devez avoir appris comment changer les principaux attributs de votre texte. Cependant, 

parfois, les document ont besoin d'être complètement remis en forme. Vous pouvez y arriver 

en changeant le style de la police ou sa taille, conjugué avec d'autres attributs pour mettre 

en  valeur  une  section  spéciale  de  votre  document  comme  :  les  titres,  les  légende,  les 

commentaires, etc.

Normalement, la police par défaut d'un document est 'Thorndale' ou 'Times New Roman'. Il 

peut arriver que vous n'aillez pas ces polices sur votre système ou que vous ne les aimiez 

pas. Vous pouvez changer la police par défaut en choissant  Outils – Options dans la barre 

de Menu et en naviguant dans la fenêtre de dialogue qui va s'ouvrir jusqu'à trouver Texte – 

Polices standards (occidentales). Là, vous pouvez changer la police par défaut des titres, 

listes, légendes et index. Malheureusement cette solution est assez radicale. En effet, cela va 

modifier la police de tous les documents que vous créez. Une alternative et sans doute une 

meilleur façon de procéder est de modifier la police et sa taille   dans le menu déroulant de 

la barre de Fonctions.

Le premier menu déroulant affiche toutes les polices installées sur votre système. Pour voir 

toute la liste, cliquez sur le bouton avec la petite flèche à droite du menu déroulant et faites 

dérouler la liste. Le second menu affiche la taille des polices exprimée en points. Sélectionnez 

un mot ou une section de texte et essayez de changer sa taille. Comme indiquez ci-dessus, 

c'est la façon la plus rapide de procéder pour mettre en forme des titres ou d'autres parties 

de textes réclamant un formatage spécial.
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 II.2 -  Le Styliste

Imaginons que vous devez écrire un long rapport avec plusieurs sections et différents styles 

de titre, et voilà qu'à 16 h 55, votre patron arrive et vous dit : 'Je préfère de l'Arial à la place 

du Verdana dans les titres, et du Georgia à la place du Times New Roman pour le texte 

normal. S'il vous plaît, changez cela avant de partir...' Bien sûr, vous n'avez que 5 mn pour 

modifier des dizaines de titres et de paragraphes !

Ce serait un terrible cauchemar si vous n'aviez écrit cela avec votre suite OOo. En fait, dans 

Writer, vous utiliserez le Styliste pour effectuer vos modifications en un temps record !

La fenêtre flottante du Styliste doit s'afficher par défaut lorsque vous ouvrez un nouveau 

document.

Si elle n'est pas affichée, cliquez sur l'icône du Styliste  que vous trouverez dans la barre 

de fonctions.

Nous nous en sommes déjà servi pour créer une nouvelle page dans la section 1. Maintenant 

nous allons en apprendre plus sur son utilisation.

La fenêtre du Styliste comporte une barre d'outils juste en dessous de la barre de titre. Elle 

se  compose  de  5  icônes  à  gauche  qui  permettent  de  passer  d'un  style  à  l'autre  : 

Paragraphe,  Caractère,  Cadre,  Page et  Numérotation.  Puis  trois  icônes  à  droite  qui 
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donnent accès à des fonctions spécifiques du Styliste : Mode Remplir Tout, Nouveau Style 

à partir de la sélection, Actualiser le Style. En dessous de cette barre, vous pouvez voir 

une fenêtre où s'affichent tous les styles répertoriés. Enfin, en bas de cette fenêtre, un menu 

déroulant vous propose différent filtres de tri de ces styles, qui vous permettront, suivant le 

filtre choisi, de n'afficher qu'une partie des styles, par exemple : 'Styles de chapitres' plutôt 

que 'Tous les Styles', ou encore 'Automatiquement'.

Après  ce  bref  aperçu,  revenons  à  l'exemple  dont  nous  parlions  au  début  de  la  section. 

Comment pouvons-nous changer tous les titres et paragraphes en quelques minutes ? Si vous 

avez utilisé les styles ponctuels,  ce sera pratiquement impossible. Cette méthode est utile 

uniquement si vous avez un ou deux titres à formater, ou bien quelques mots, rien de plus. 

Au contraire, avec les styles  du Stylistes (aussi  appelés 'styles  dynamiques) vous avez la 

possibilité  de modifier plusieurs sections de textes et même tout un livre si nécessaire en 

quelques clics de souris. Voyons comment cela peut se faire :

• Cliquez sur la première icône appelée 'Style de paragraphes', pour afficher tous les 

styles relatifs aux paragraphes. Vous pouvez remarquer qu'il y a quelques styles qui 

sont déjà prêts à être utilisés,

• Pour les appliquer au texte que vous avez écrit, vous pouvez choisir entre :

1. sélectionner le texte auquel vous souhaitez appliquer le style, puis double cliquer sur 

le style à l'intérieur du styliste, et ce style sera appliqué immédiatement,

2. cliquez une fois sur le style à l'intérieur du Styliste et cliquez à nouveau sur l'icône 

'Mode  Remplir  Tout' .  Cet  outil  restera  sélectionné  jusqu'à  ce  que  vous  le 

désélectionniez. Le curseur va changer en une ligne gris clair et le pointeur de la souris 

en un pot de peinture. Quand vous allez cliquer à l'intérieur du paragraphe ou du titre, 

tout le texte de ce paragraphe ou de ce titre va être modifié.

Il est facile à comprendre qu'une composition utilisant les styles est très facile à modifier en 

utilisant les styles préenregistrés dans le Styliste. Il existe une fonction très pratique pour 

modifier et personnaliser les styles.

Pour modifier un style :

1. Assurez-vous que le style Paragraphe est sélectionné, puis choisissez le style désiré en 

faisant un clic gauche sur celui-ci, il sera sélectionné.

2. Puis,  faites un clic  droit  sur le style sélectionné pour activer le menu contextuel  et 

choisissez 'Modifier...'

3. Dans la boite de dialogue qui apparaît, vous pouvez modifier les attributs  que vous 
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désirez,

4. Cliquez sur OK pour confirmer votre choix et refermer la fenêtre de dialogue

Note : si vous avez modifié directement un style dans votre document (appliqué de nouvelles polices, couleurs ou 

taille, etc.) vous devez mettre à jour le style correspondant dans le Styliste, ainsi toutes les sections formatées avec ce  

style seront mises à jour automatiquement. Pour faire cela :

• Sélectionnez le texte modifié et cliquez sur l'icône 'Actualiser le Style'  dans le Styliste,ou,

• glissez le texte sélectionné jusqu'au style voulu dans le Styliste, le style sera automatiquement actualisé.

Pour créer un nouveau style :

1. Répétez l'étape 1 listée au-dessus. Rappelez-vous que votre nouveau style va hériter 

des caractéristiques du style que vous avez sélectionné, donc, soyez attentif  à celui 

que vous choisissez.

2. Faites  un  clic  droit  sur  le  style  sélectionné  pour  afficher  le  menu  contextuel,  puis 

choisissez Nouveau...,

3. Tapez le nom de votre nouveau style sous l'onglet Organiser de la fenêtre de dialogue 

qui apparaît,

4. Sélectionnez  le  nom du  style  qui  doit  suivre,  dans  votre  document,celui  que  vous 

venez juste de créer. Par défaut, un style de paragraphes est suivi par le même style, 

mais il  peut arriver que vous préféreriez adopter une autre méthode de travail.  Par 

exemple,  après  un  titre  de paragraphe,  vous  voudrez  peut-être  que  le  paragraphe 

suivant soit dans un style standard, ou dans un style de titre de niveau inférieur. Si 

vous  sélectionnez  ce style  dans  cette  fenêtre,  il  sera automatiquement  sélectionné 

après que vous appuyez sur la touche entrée de votre clavier. C'est une bonne façon 

d'économiser votre temps !

5. Modifiez tout ce que vous désirez modifier : polices, tabulations, couleur de premier et 

d'arrière plan, etc.,

6. Confirmez votre choix en cliquant sur la touche OK et pour fermer la boite de dialogue.

Conclusion, votre document sera prêt en 5 minutes si :

1. Vous modifiez la taille de police des paragraphes et de titres en modifiant les styles 

préenregistrés  dans le Styliste  comme expliqué  ci-dessus.  Tous les  paragraphes ou 
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titres formatés dans le même style seront tous automatiquement actualisés,

2. Au cas où vous devriez faire de profonds changements ou que votre patron ait des 

prétentions plus importantes ! Vous pouvez créer un style complètement nouveau et 

l'appliquer à l'aide de la commande 'Mode Remplir Tout'.
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 II.3 - Description d'un document

Contient des informations descriptives sur le document.

Accès à cette fonction :

Menu Fichier - Propriétés... - Onglet Description

Titre : Saisissez un titre pour le document. Le titre peut différer du nom du fichier. Le titre 

s'affiche dans la barre de titre du document.

Sujet : Saisissez un objet pour le document. Vous pouvez utiliser un objet permettant de 

grouper les documents de contenu similaire.

Mots-clés : Saisissez les mots à utiliser pour indexer le contenu du document.

Description : Saisissez des commentaires aidant à identifier le document.

 II.4 - Mise en page du document

Cliquer sur Format, Page pour avoir la boîte de dialogue suivante :

Cliquez sur l'onglet Page. La boîte de dialogue suivante apparaît.
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  II.4.1 - 

  II.4.2 - Format de papier

Format : Dans la zone de liste  Format, sélectionnez le format prédéfini  pour l'édition sur 

papier ou à l'écran. (A4, A3,....)

Largeur : Permet de saisir une largeur de papier différente de la valeur prédéfinie.

Hauteur : Permet de saisir une hauteur de papier différente de la valeur prédéfinie.

Orientation :  Sélectionnez  le  bouton  radio correspondant  à l'orientation  que vous voulez 

donnez à votre document (Portrait ou Paysage)

Source du papier : Si votre imprimante est équipée de plusieurs bacs d'alimentation papier, 

cette zone de liste vous permet de déterminer quel bac d'alimentation doit être utilisé. 

  II.4.3 - Marges 

Utiliser pour définir l'écart des caractères par rapport aux bords de la page.(A gauche, A 

droite, En haut, En bas)
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  II.4.4 - Paramètres de mise en page

La sélection de la mise en page vous permet d'en définir la portée.

Mise en page

Cette  zone  combinée  permet  de  déterminer  dans  quelles  pages  du  document  les 

paramètres identifiés sont appliqués. Elle peut prendre les valeurs suivantes:

Pages de droite et de gauche : Les paramètres identifiés sont appliqués sur toutes les 

pages du document.

Pages en vis à vis : Cette mise en page s'applique aux documents imprimés en recto-

verso, pour brochage ou reliure.

Pages de droite : Les paramètres identifiés ne s'appliquent qu'aux pages de droite. La 

première page d'un document est toujours une page de droite.

Pages de gauche : Les paramètres identifiés ne s'appliquent qu'aux pages de gauche.

Format

Dans cette zone combinée, sélectionnez le type de numérotation des pages.

 II.5 - Encadrer un texte

Sélectionner le texte à encadrer

Cliquez sur Insertion, Cadre. La boîte de dialogue suivante apparaît:
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 II.6 - Numérotation des  pages

Pour numéroter simplement vos pages, c'est à dire tous les numéros se suivent :

• positionner le curseur dans le pied de page en cliquant sur Insertion, Pied de page, 

Standard

• utiliser  la  touche  tabulation  de votre  clavier  pour  positionner  le  curseur  là  où vous 

voulez insérer le numéro (gauche, centre ou droite)

• dans le menu Insertion cliquez sur Champs, Numéro de page.

Les numéros successifs apparaissent sur les pages en commençant par la première. Si du 

texte apparaît à la place du numéro, aller dans le menu Affichage et décocher Champs.

Pour empêcher l'affichage du numéro sur la première page, faite l'opération suivante avant 

l'insertion des  numéros :

• placer le curseur sur la première page

• cliquez sur Format, Styliste

• dans la fenêtre  Styles de page qui s'affiche, cliquez sur l'icône  Styles de page puis 

double-cliquez sur la valeur Première page.
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 II.7 - Numérotation des sections

Commençons par numéroter les sections de types Titre 1 & Titre 2. Cela se passe dans le 

menu Outils, Numérotation des chapitres. Vous obtiendrez la fenêtre suivante:

Dans le colonne  Niveau, on indique le niveau à numéroter. Pour chaque niveau on choisit 

principalement le style de titre à associer (style de paragraphe) et le style de  numéros 

voulus (Numéro). Par exemple pour le Niveau 1 on choisit le style de paragraphe Titre 1 et 

le style de numéro  I, II, III, ... et pour le  Niveau 2 le style de paragraphe  Titre 2 et la 

numérotation 1, 2, 3, ...

Nous avons aussi  la possibilité  d'ajouter des espaces et/ou d'autres séparateurs  en avant 

et/ou en arrière des numéros en utilisant les champs positionnés à cet effet.

 II.8 - Insertion de la Table des matières

OpenOffice va se servir des niveaux de titre que vous avez déterminés pour pour 

construire  la  table  des matières,  d'où l'importance  de bien hiérarchiser  votre  texte.  Vous 

insérer la table des matières en début ou fin de document. Vous pouvez l'actualiser après 

chacune de vos modifications par un simple clic!
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1. Placez le curseur à l'endroit du texte où vous voulez insérer la table des matières.

2. Sélectionnez la commande de menu Insertion - Index - Index. La boîte de dialogue 

Insérer un index s'affiche. 

3. Sur l'onglet Index, vous avez la possibilité de nommer votre table des matières dans le 

champ Titre. Dans la liste déroulante qui apparaît devant le champ Type, sélectionnez 

le type "Table des matières" (lors de la première ouverture, l'onglet et le type sont 

présélectionnés).

4. Laisser la case  Protégée contre toute modification manuelle cochée si  vous ne 

voulez pas intervenir directement dans la table des matières.

5. Créez un index sur votre  Document entier et modifiez la  Profondeur de niveaux 

jusqu'à atteindre celui que vous désirez (on entend par là les niveaux de titre)

6. Cliquez alors sur OK, si vous voulez que la table des matières soit générée à partir de 

la  structure du  document  (ses  titres)  et  d'éventuelles  marques  d'index  que  vous 

aurez vous-même saisies.

7. Créer à partir de : Dans cette zone, spécifiez les informations que vous souhaitez 

inclure dans un index.

Structure :Crée  l'index  en  utilisant  les  niveaux  de  plan  :  les  paragraphes 

formatés       avec l'un des styles de titre prédéfinis (Titre 1-10) sont ajoutés à l'index.

« ... »  : Ouvre la boîte de dialogue  Numérotation des chapitres dans laquelle  

    vous pouvez assigner des styles de paragraphe aux niveaux de plan.
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Styles supplémentaires : Inclut les styles de paragraphe spécifiés dans la boîte 

   de dialogue Assigner le style en tant qu'entrées d'index. Pour sélectionner les 

   styles de paragraphe à inclure dans l'index, cliquez sur le bouton  ...  situé à 

    droite de cette case à cocher.

« ... » : Ouvre la boîte de dialogue Assigner le style dans laquelle vous 

   sélectionnez les styles de paragraphe à inclure dans l'index.

Marques d'index :Inclut dans l'index toutes les entrées d'index que vous avez 

    insérées par le biais de la commande de menu Insertion - Index - Entrée.

Si vous effectuez ultérieurement une modification des titres, un changement de leur ordre ou 

une insertion de nouveaux chapitres, vous devez actualiser la table des matières.

• Placez  le  curseur  dans  la  table  des  matières.  Activez  le  menu  contextuel  et 

sélectionnez la commande Actualiser l'index.

 II.9 - Personnalisation des barres d'outils

Vous permet d'adapter les barres d'outils à vos exigences personnelles.

Comment accéder à cette fonction...

• Menu Affichage - Barre d'outils – Personnaliser..., ou 

• Menu Outils - Adaptation - onglet Barre d'outils – bouton Personnaliser...
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Dans  la boîte de dialogue, faire :

1. Dans la fenêtre   Boutons disponibles  à gauche, sélectionner une catégorie. Cliquer 

sur le « + » pour voir les icônes disponibles sur cette catégorie. 

2. Cliquer sur l'icône que vous voulez afficher, puis cliquer sur le boutou « Ajouter --> », 

l'icône apparaît dans la fenêtre Boutons utilisés à droite, cocher la case qui apparaît 

devant si elle ne l'est pas.

Consultez également le menu contextuel de la barre d'outils. Vous y trouverez sous 

Boutons visibles une liste de toutes les icônes contenues dans la barre, réparties par 

icônes affichées actuellement et icônes masquées. Les icônes affichées sont indiquées 

par une coche. Cliquez sur une icône dépourvue de coche pour l'afficher dans la liste.

Exemple: « Pour ajouter l'icône aperçu avant impression » faire :

• Menu Affichage - Barre d'outils – Personnaliser

• Dans Boutons disponibles, cliquez sur Affichage,

• Cliquer sur l'icône Aperçu puis sur le bouton Ajouter -->

• Le bouton aperçu apparaît dans la fenêtre Boutons utilisés.
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• Cliquer sur OK pour terminer l'opération

 II.10 - Travailler avec des Tableaux

  II.10.1 -  Insérer un tableau :

Avant de faire votre tableau, vous devez décider au moins de sa structure (nombre de lignes, 

nombre de colonnes, orientation,  ...), vous perdrez ensuite  ainsi  moins de temps dans sa 

conception. Même si tout est ensuite modifiable, cela sera plus simple si vous connaissez à 

peu près la largeur qu'il doit avoir, s'il doit être en mode paysage ou portrait, bref, quelques 

bases de construction.

Pour insérer un tableau dans une page, vous avez plusieurs possibilités :

• soit vous choisissez le menu Insertion > Tableau, 

• soit vous utilisez le raccourci clavier ctrl+F12, 

• soit  dans  la  barre  d'instruments  située  à  gauche  de  votre  écran  (barre  latérale)  vous 

choisissez l'icône Insérer. Lorsque vous cliquez sur cette icône, si vous laissez votre doigt 

un peu longtemps sur la touche de la souris, vous développez une barre d'outils qui vous 

montre toutes les possibilités d'insertion. A nouveau, si vous cliquez sur l'icône Insérer un 

tableau, vous voyez une grille s'afficher. En déplaçant votre souris sur cette grille vous 

allez pouvoir sélectionner le nombre de cellules (lignes et colonnes) à insérer dans votre 

tableau.
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Remarquez qu'en plus de l'affichage en bleu de la sélection, le nombre de ligne et de colonne 

s'inscrit en bas du cadre (3 colonnes et 4 lignes pour notre illustration).

• Si  vous  faites  juste  un  clic  rapide  sur  l'icône  Insérer  de  la  barre  d'instruments,  une 

fenêtre s'ouvre vous demandant de préciser les valeurs  pour les lignes et les colonnes.

D'autres options, un peu plus précises s'affichent. Vous pouvez ainsi nommer votre tableau, 

en déterminer le nombre de colonnes et de lignes. Examinons les options proposées :

− Titre : la première ligne de votre tableau sera formatée avec le style Titre de tableau, par 

défaut,

− Répéter sur chaque page : votre titre se répétera automatiquement au début de chaque 

nouvelle page comportant ce tableau.

− Ne pas scinder le tableau : cela permet, lors d'une éventuelle modification de mise en 

page, que votre tableau ne se retrouve pas coupé en deux,

− Bordure : affiche une bordure autour des cellules du tableau.

Examinons maintenant les boutons de cette même fenêtre de dialogue, que signifie donc ce 

bouton AutoFormat... ? 
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Si vous cliquez dessus, voici la nouvelle fenêtre qui s'ouvre :

Et  oui, cette fenêtre  va vous proposer un ensemble  de présentations de tableau. Voyons, 

sélectionnons Bleu  dans la liste de gauche pour voir ce qu'il se passe 

Une mise en forme des cellules, du fond et de la page vous est proposée. Si celle-ci vous 

convient,  il  vous  suffit  d'appuyer  sur  OK pour  que  ce  tableau  vide  s'insère  dans  votre 

feuille  :
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Il ne vous reste plus qu'à le remplir de vos données.

Lorsque vous regardez l'ensemble des boutons à droite de la boite de dialogue, tout en bas 

figure un bouton  Options muni  de deux flèches vers la droite  >>. Si  vous cliquez sur ce 

bouton, la fenêtre de dialogue s'agrandit pour vous proposer à nouveau des choix :

Avant de détailler ces choix, observez à nouveau le bouton, les flèches ont changé de sens, 

juste pour vous informer que les Options sont affichées.

Intéressons-nous maintenant à ces nouvelles options de formatage :

− Format numérique : si votre tableau est constitué de données numériques, ce format 

sera pris en compte dans l'autoformat.
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− Police : là aussi, la police sera prise en compte dans l'autoformat,

− Alignement : les données seront alignées les unes par rapport aux autres,

− Bordure, motif : bordure et/ou motif seront reproduits.

Vous pouvez bien-sûr ajouter les AutoFormats qui vous conviennent. Pour cela, créez votre 

tableau avec les formatages, couleurs, bordures qui vous conviennent. Laissez votre curseur 

dans le tableau et dans le menu Format, choisissez AutoFormat.

Une fenêtre telle que celle-ci dessus s'ouvre, mais cette fois-ci, le bouton Ajouter n'est plus 

grisé.

− cliquez sur ce bouton Ajouter

− une fenêtre s'ouvre et vous demande de Nommer votre format (nous l'appelons 'Perso')

− cliquez sur OK

− votre AutoFormat apparaît maintenant dans la fenêtre de dialogue 

Vous pouvez Supprimer ce format s'il ne vous convient plus en le sélectionnant dans la liste 

de gauche et en appuyant sur le bouton Supprimer.

Essayez  les  différents  formats  et  leurs  pré  réglages  pour  connaître  ceux  qui  vous  seront 

fonctionnels,  ceux-ci  représentent  un  réel  gain  de  temps  dans  la  présentation  de  vos 

données.

  II.10.2 -  Formater les cellules

Voyons maintenant comment créer un tableau en formatant les cellules. Vous avez choisi un 

nombre de lignes et de colonnes et votre tableau tout vide est inséré dans votre feuille. Le 

curseur  s'est  positionné  automatiquement  dans  la  première  cellule  supérieure,  centré,  en 

italique.

Observons maintenant notre écran dans son ensemble. 

Tout  d'abord,  la  barre  d'objets  située  en  haut  de  votre  écran  s'est  modifiée,  les  icônes 

relatives au traitement de texte ont disparu et vous disposez de celles traitant du tableau.

Toutefois, regardez bien tout au bout de cette barre, un petit triangle bleu vous permet, si 

vous cliquez dessus, de revenir à la barre d'outils de traitement de texte, vous en bénéficiez 

Support de formation OpenOffice.org Writer                                         Page:     26   sur 

53



effectivement à l'intérieur des cellules que vous traitez avec du texte.

Ouvrez le Navigateur (F5) et le Styliste (F11).

Le Navigateur  fait  maintenant  apparaître  le  tableau que vous avez inséré.  Un 

double  clic  sur  cette  ligne  du  Navigateur  vous  amènera  directement  dans  le  tableau,  à 

quelqu'endroit que vous soyez dans votre document.

La  vue  du  Styliste  vous  indique  le  style  prédéfini  que  vous  utilisez  (vous 

retrouvez ce style dans la barre d'outils contextuelle qui s'est affichée).

Voyons maintenant la barre d'état, en bas de votre page écran.

Pleine d'informations, elle vous indique (à partir de la gauche) la page sur laquelle vous êtes, 

le style de page utilisé (standard dans notre cas), le zoom, les boutons habituels d'insertion, 

de sélection ou d'hyperlien et l'emplacement de la cellule dans laquelle votre curseur est situé 

(A1 pour nous).

Pourquoi A1 ? Et bien votre tableau reprend certaines des fonctions des tableurs, à savoir que 

pour se repérer dans une feuille de calcul, on nomme habituellement les cellules des lignes 

(horizontales)  avec  des  nombres,  et  celles  des  colonnes  (verticales)  avec  des  lettres  de 

l'alphabet. Ainsi si je veux nommer cette cellule qui se situe sur la 3e ligne de la 2e colonne, 

je l'appellerai B3.

Bon allons-y maintenant, nous allons modifier cette ligne de titre dont le formatage ne vous 

convient pas.

Pour  modifier  réellement  le  style,  dans  le  Navigateur,  faites  un  clic  droit  sur  Titre  de 

Tableau, et choisissez  Modifier.  Cliquez sur l'onglet  Police et modifiez les attributs  tels 

qu'ils vous conviennent
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La fenêtre de dialogue qui s'ouvre va vous permettre d'intervenir  sur le formatage de ces 

cellules.

Profitez-en pour cliquer sur les autres onglets pour régler les différents paramètrages, l'onglet 

arrière plan par exemple vous permettra de déterminer une couleur d'arrière plan pour ces 

cellules de titre. Attention, j'ai dit pour les cellules, par pour le tableau. La différence ? la 

voici :

L'arrière  plan  tient  compte de l'écart  avec la  bordure du tableau,  il  ne  s'applique  qu'à la 

cellule. Ainsi, on peut faire ceci en ajoutant un arrière plan au tableau.
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Il peut vous arriver également de devoir séparer une cellule en deux ou plus. Pour cela vous 

allez devoir 'scinder' la cellule :

− placez votre curseur dans la cellule concernée,

− faites un clic droit avec la souris pour obtenir le menu contextuel, ou cliquez sur l'icône 

'scinder' de la barre d'outils

− une boite de dialogue apparaît vous demandant le sens (horizontal ou vertical) dans lequel 

vous souhaitez scinder cette cellule et le nombre de cellules que vous voulez obtenir

C'est alors la cellule sélectionnée qui est divisée en autant de cellules que demandé, les 

autres autour ne bougeant pas. Très différent de si vous ajoutez une ligne ou une colonne 

dans votre tableau.

  II.10.3 -  Formater le tableau 

Nous venons d'en avoir l'exemple, formater les cellules et formater le tableau ne signifie pas 

la même chose. Choisissez la ou les cellules sur lesquelles vous voulez intervenir :

− sélectionnez la ligne, ou positionnez votre curseur dans n'importe quelle cellule du tableau 

et 

− affichez les options de formatage du tableaux

. soit en sélectionnant le menu Format > Tableau,

. soit en faisant un clic droit et en sélectionnant Tableau dans le menu contextuel,

Une fenêtre de dialogue telle que celle ci-dessous s'ouvre :
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Sous l'onglet  Tableau, vous pouvez nommer votre tableau. Cela vous permettra ensuite 

de l'identifier très facilement dans le Navigateur par exemple.

− les Ecarts qui sont indiqués sont ceux entre le tableau et le reste de la page. La taille du 

tableau  étant  par  défaut  limitée  par  les  marges  droites  et  gauches,  ces  options  sont 

grisées pour le moment.

− de même, l'alignement du tableau par rapport à la page est Automatique par défaut, mais 

vous pouvez très bien le déplacer dans la page à partir de ces options.

− le bouton Réinitialisation que vous voyez tout en bas de cette fenêtre de dialogue vous 

permet de revenir aux valeurs de départ, avant vos modifications.

Cliquons maintenant sur l'onglet Enchaînement :
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L'enchaînement détermine le comportement du tableau par rapport au reste du document. 

Dans la copie d'écran ci-dessous, nous avons indiqué un Saut de Page Avant, ceci en cliquant 

sur les boutons radios situés devant ces options. Cela veut dire que lorsque nous fermerons 

cette boite de dialogue, le tableau sera insérée sur une nouvelle page.

Vous pouvez donc déterminer  un saut de page Avant  ou Après le tableau,  ou bien,  si  ce 

tableau est dans une Colonne, un saut de Colonne avant ou après.

− Avec le style de page : si vous cochez cette case, vous allez pouvoir déterminer le style 

de la nouvelle page sur laquelle le tableau va se placer (cette option est donc liée à la 

précédente) et indiquer également un numéro de page si vous le souhaitez différent de la 

numérotation en cours.

− les options suivantes sont assez explicites, il s'agit de conserver des options de mise en 

page à travers le document.

Intéressons nous maintenant à l'onglet suivant de cette boite de dialogue, l'onglet Colonnes:
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Regardons pour le moment la largeur des colonnes, pour vous, elles doivent apparaître toutes 

identiques. Et si vous essayez de modifier une largeur, celle de droite se modifie également. 

Plus encore, vous n'avez pas accès aux choix 'Adapter la largeur du tableau' ou 'Modifier 

les colonnes proportionnellement'. Comment faire pour arriver à ce résultat ?

Nous avons d'abord fait une modification manuelle directement sur le tableau. Vous pouvez 

en  effet  intervenir  directement  sur  votre  tableau  sans  avoir  à  passer  par  cette  boite  de 

dialogue.

Lorsque vous déplacez votre curseur sur le tableau, si vous arrivez à le placer sur une ligne 

qui sépare deux colonnes, vous constatez que celui-ci change de forme et devient une petite 

barre munie d'une flèche vers la droite et une autre vers la gauche. Si vous faites un clic 

gauche de votre souris et que vous maintenez votre doigt appuyé, vous allez pouvoir déplacer 

les lignes des cellules vers la droite ou la gauche.

Amusez-vous,  essayez-le  et  décalez  également  les  lignes  qui  sont  près  de  la  marge. 

Maintenant ouvrez de nouveau la boite de dialogue Format > Tableau > onglet Colonnes. 

Vous obtenez pratiquement la même chose que celle que nous voyons ci-dessus cette fois-ci 
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avec les case à cocher accessibles :

− Espace disponible : vous indique en cm l'espace disponible restant dans le tableau par 

rapport aux marges,

− Adapter la largeur du tableau : vous permettra de modifier la taille de la cellule sans 

modifier  la  taille  de celle  située  à sa droite  (comportement  que vous avez observé au 

départ),

− Modifier  les  colonnes  proportionnellement  :  toutes  les  colonnes  seront  modifiées 

proportionnellement aux modifications que vous entrez et à l'espace disponible.

Bien revenons maintenant aux autres onglets de notre boite de dialogue Format > Tableau. 

Celui-ci est important pour la lisibilité du tableau, il s'agit de l'onglet Bordure :

Dans le cadre Disposition des lignes, vous choisissez quelles lignes sont concernées par vos 

modifications.  Si  vous  cliquez  sur  l'un  des  petits  triangles  de  la  fenêtre  Défini  par 

l'utilisateur, vous pouvez afficher ou supprimer un trait. 

Le menu Ligne va déterminer le style et la couleur des traits.

Ecart avec le contenu, détermine l'écart entre ce que vous avez inscrit dans la cellule et le 
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trait  qui  entoure  celle-ci.  L'option  Synchroniser affichera  le  même écart  pour  toutes  les 

cellules du tableau. C'est donc avec cette option que vous devez jouer si vous souhaitez par 

exemple n'avoir un écart que dans la première cellule.

De même vous pouvez ajouter une ombre à cette  bordure, qui  pourra être d'une couleur 

différente de celle de la bordure par le l'option Ombre.

Et pour parfaire notre chef-d'oeuvre, intéressons-nous au dernier onglet, celui qui permet de 

mettre un Arrière-plan.

Très simple  d'utilisation,  vous choisissez  vous-même ce à quoi  vous  voulez  appliquer  cet 

arrière-plan en utilisant la liste déroulante qui se trouve devant  Pour  : Tableau, Cellule ou 

Ligne (il faut tout de même sélectionner la cellule ou la ligne à laquelle vous voulez appliquer 

l'arrière-plan).

Ensuite très simple, clic sur la couleur désirée dans le nuancer et puis voilà !
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Pour fermer la boite de dialogue et faire prendre en compte toutes vos modifications, appuyez 

sur le bouton OK.

  II.10.4 -  Insérer une légende 

Il arrive bien souvent que dans un texte, vous souhaitiez insérer une légende à votre tableau, 

cela facilite sa lisibilité.

Vérifiez que votre curseur est bien placé dans votre tableau, n'importe quelle  cellule, cela 

n'importe pas.

− dans le menu Insertion, choisissez Légende

− voici la fenêtre qui s'ouvre :

− le  programme a déterminé de lui-même qu'il  s'agissait  de légender le tableau,  vous le 

vérifiez par la Catégorie indiquée

− choisissez ensuite, en faisant se dérouler le menu, le style de numérotation de légende 

que vous souhaitez,

− Dans la case Texte de la légende, inscrivez le commentaire de votre tableau. Insérez un 

espace avant de façon à ce qu'il ne soit pas collez au nom du tableau. Vous pouvez vérifier 

l'apparence en haut de la boite de dialogue;

− Position vous indique si vous souhaitez que votre légende apparaisse en haut (supra) ou 

en bas de votre tableau (infra), 
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− enfin la dernière case, Nom de l'objet, vous permet de vérifier que vous légendez bien le 

tableau désirez en vous rappelant son nom. Vous ne pouvez modifier le nom de l'objet si 

par exemple vous vous êtes trompé de tableau à légender.

  II.10.5 -  Les données du tableau

Vous l'avez vu plus  haut,  la présentation  de votre  tableau vous est  facilité  par un grand 

nombre d'outils. Il en est de même pour le traitement des données de votre tableau. Ainsi 

vous allez pouvoir utiliser certaines des fonctions d'un tableur, pour effectuer vos calculs.

Les calculs simples

Vous souhaitez effectuer un total dans votre tableau, rien de plus simple : 

− insérez votre tableau,

− entrez vos données à additionner les unes en dessous des autres dans une colonne, 

− terminez cette colonne en tapant le signe égal [=] dans la dernière cellule 

− que s'est-il produit ? le signe égal ne s'est pas inscrit dans la colonne, mais dans une barre 

en haut de l'écran
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La barre d'outils s'est transformée en une barre de calcul.

− sélectionnez maintenant la colonne dans laquelle se trouve les nombres à additionner,

− appuyez sur Entrée

− le total de la colonne s'affiche dans la cellule où vous avez tapé le signe [=] !

Dans la barre d'outils, cliquez maintenant sur l'icône représentant un Sigma qui correspond à 

la barre de calcul  et qui va vous révéler la ligne que vous avez en fait écrite.

Cette barre vous indique la cellule dans laquelle la fonction est écrite, et la fonction en elle-

même.

Intéressons  nous  maintenant  aux  icônes  qu'elle  contient.  La  première  comporte  un  petit 

triangle  vert,  ce qui  veut dire dans OpenOffice.org en général,  qu'elle  cache autre chose. 
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Cliquons dessus un peu longtemps pour en voir le menu :

Voici  en  faites  toutes  les  opérations  que  vous allez  pouvoir  effectuer  dans  votre  tableau, 

puissant non ?

Nous  n'allons  pas  détailler  ici  toutes  ces  fonctions,  le  but  est  que  vous  sachiez  qu'elles 

existent et où les trouver, si vous souhaitez vous en servir, l'aide vous expliquera la syntaxe 

de leur utilisation. Dans l'aide, inscrivez alors le mot-clé Tableau, puis sélectionner Calcul, 

barre de Calcul et Formules. 

Mais  continuons  à inspecter  notre  barre  de calcul,  l'icône  en forme de croix  rouge,  vous 

permet d'annuler la formule que vous venez d'inscrire, la petite coche verte au contraire de la 

valider. L'espace blanc situé après cette coche, est l'endroit ou vous saisissez votre formule.

Note : les fonctions de calcul sont toujours active dans un document texte, même si votre 

curseur n'est pas dans la cellule d'un tableau. 

Exemple :

− prenez une page vierge et inscrivez la phrase suivante : 'Si je calcule 12 * 2 + 3 alors 

j'otbiens le résultat suivant',

− maintenant mettez en surbrillance 12 * 2 + 3 et appuyez sur la combinaison de touche ctrl 

+ ou encore choisissez Calculer dans le menu Outils,

− le  résultat  va  être  inséré  dans  le  presse  papier  (vous  ne  le  verrez  donc  pas  pour  le 

moment)

− placez votre curseur à l'endroit où vous souhaitez insérer votre résultat et faites un simple 

'Coller' ou la combinaison de touche ctrl v, le résultat de l'opération ci-dessus s'inscrit.
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De la même façon que nous avons fait des calculs dans un tableau, vous pouvez en effectuer 

sur plusieurs. Puisque vos tableaux sont nommés (par défaut Tableau1, Tableau2...), vous 

pouvez très bien indiquer dans votre formule la référence à la cellule d'un autre tableau. Ou 

simplement  comme  nous  l'avons  fait  écrire  =  dans  une  cellule  du  second  tableau  et 

sélectionner les cellules du premier pour le calcul.

Note : OpenOffice.org comporte un bug. Si votre tableau n'a qu'une cellule et qu'elle dépasse 

la longueur de la page, alors le texte n'est pas reporté sur l'autre page, mais disparaît. 

  II.10.6 -  Trucs et astuces 

Insérer un paragraphe au-dessus d'un tableau

Vous  avez  insérez  votre  tableau  dans  une  page,  en  haut  de  cette  page  et  souhaiteriez 

maintenant  ajouter  un  paragraphe  avant  votre  tableau.  Problème,  aucune  marque  de 

paragraphe n'apparaît !

− placez votre curseur dans la cellule en haut à gauche de votre tableau,

− appuyez simplement sur la touche entrée, votre tableau se décalera d'une ligne vers le bas 

faisant apparaître une marque de paragraphe au-dessus.

Reconnaissance des nombres

Lorsque vous rentrez des nombres dans votre tableau, vous souhaitez soit qu'ils soient pris 

en  compte  et  alors  alignés  à  droite  dans  votre  cellule  ou  non  pris  en  compte  et  ainsi 

considérés comme du texte qui s'aligne à gauche de la cellule.

− dans le menu Outils, sélectionnez Options

− dans la liste de droite, sélectionnez Texte, puis Tableau,

− dans  la  fenêtre  qui  s'ouvre,  cochez  la  case  Reconnaissance  des  nombres si  vous 

souhaitez que cette fonction soit active.

Notez que dans cette fenêtre, vous retrouvez des options que nous avons déjà vu ailleurs. Le 

fait de les paramètre dans cette fenêtre, les positionnera par défaut à chaque fois que vous 

insérerez un tableau.

Attention, si la reconnaissance des nombres est activée et que vous souhaitez entrer 20.1 

dans une cellule, ce nombre sera considéré comme une date ! Vous devez vous servir de la 
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virgule, ou encore désactiver momentanément la reconnaissance des nombres en faisant un 

clic droit avec votre souris. Dans le menu contextuel qui s'affiche, cliquez sur Reconnaissance 

des nombres pour désactiver l'option (la coche devant s'effacera).

Protection/Déprotection d'un tableau

Writer vous offre la possibilité de protéger une cellule, plusieurs cellules, votre tableau.

Pour cela, 

− sélectionnez les parties que vous souhaitez protéger contre l'écriture,

− dans le menu Format, choisissez Cellules > Protéger.

− les cellules sélectionnées sont maintenant protégées en écriture, si vous tentez de saisir 

dedans, une fenêtre s'affichera vous notifiant la protection du tableau.

Pour déprotéger votre sélection :

− cliquez  à  nouveau  sur  Format >  Cellules et  cette  fois-ci  sélectionnez  Annuler  la 

Protection.

Une  autre  méthode  consiste  à utiliser  le  Navigateur,  vous  pouvez  ainsi  déprotéger  votre 

tableau de n'importe où dans votre document :

− affichez le Navigateur (F5 ou cliquez sur l'icône)

− à la rubrique Tableau de la fenêtre d'affichage, déroulez le contenu (cliquez sur la petite 

croix devant tableau)

− sélectionnez le tableau que vous souhaitez déprotéger et faites un clic droit pour afficher le 

menu contextuel et cliquez sur Annuler la protection.

−
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Remarques sur ce menu contextuel :

− Editer : éditera la fenêtre de formatage du tableau,

− Supprimer : supprimera le tableau. Faites attention car aucun choix de confirmation n'est 

demandé. Si vous le supprimez par erreur, pensez tout de suite à faire ctrl z.

− Renommer :  vous permettra  de renommer votre  tableau.  Attention,  si  ce  tableau est 

utilisé  pour  un  calcul  dans  un  autre  tableau,  l'autre  tableau  comportera  une  formule 

érronée, le nom du tableau de référence ayant changé.

Supprimer un tableau

Ca, c'est agaçant, vous avez beau sélectionner le tableau et appuyer sur supprimer, rien n'y 

fait, il est toujours là !

Vous l'avez vu maintenant  dans le paragraphe précédent, vous pouvez le faire à l'aide du 

navigateur.

L'autre méthode consiste à sélectionner ce tableau, mais en prenant la marque de paragraphe 

située avant (vous avez vu plus haut comment l'insérer) et la marque de paragraphe située 

après, puis d'appuyer sur la touche Suppr.
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 II.11 - Suivi des modifications dans un document

Les modifications  apportées à un texte peuvent  être enregistrées et suivies  par différents 

auteurs. Ainsi, lorsque vous récupérez le document une fois que votre collègue y a apporté sa 

contribution,  il  vous  suffit  d'afficher  les  modifications  pour  les  voir  apparaître  dans  le 

document et vous n'avez plus qu'à les accepter ou les rejeter.

De même, lorsque c'est vous qui devez corriger le document, il vous suffit d'enregistrer les 

modifications pour qu'elles apparaissent ensuite chez votre collègue. 

Voyons comment cela se passe, lorsque vous enregistrez vos modifications :

- sous Édition, sélectionnez Modification...

- dans le sous-menu, cliquez sur Afficher, pour que ce que vous faites apparaisse et cliquez 

également sur Enregistrer. Maintenant, chaque fois que vous taperez quelque chose dans le 

texte, cela apparaîtra de cette façon :

• en rouge souligné simple pour une insertion,

• en gras pour la modification d'un attribut (gras, italique ou souligné)

• barré pour une suppression.

Et toujours une marque dans la marge. 

Vous allez vous dire qu'au bout d'un moment, il doit être difficile de relire ce que l'on vient 

d'écrire et de se rendre compte de la cohérence. Pas de problèmes, cliquez simplement sur 

Édition -> Modifications et déselectionnez Affichage, votre texte apparaît normalement, 

avec les modifications prisent en compte toutefois. 

Pour  faire  ressortir  de  nouveau  vos  modifications,  refaites  le  chemin  Édition  -> 

Modifications -> Affichage.

Vous pouvez également protéger vos modifications par un mot de passe de façon à ce qu'une 

tierce personne ne puisse intervenir dessus. Sous Édition -> Modifications, sélectionnez 

Protéger l'historique.... Dans la fenêtre qui s'affiche, entrez un mot de passe contenant 

au moins 5 caractères. De cette façon, seule la personne connaissant le mot de passe aura 

accès à la fenêtre de dialogue 'Accepter ou Rejeter les modifications' décrite plus haut.
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Enfin,  vous  avez  encore  la  possibilité  d'ajouter  un  commentaire  à  une  modification. 

Imaginons que vous n'êtes pas sûre du texte à supprimer et que vous voudriez l'avis de votre 

collègue, ajoutez donc une commentaire. Positionnez votre curseur sur une partie modifiée, 

toujours sous le menu Édition -> Modification, sélectionnez Commentaire. Voici la fenêtre 

qui s'ouvre :

Ajoutez votre commentaire et cliquez sur OK. Si vous avez plusieurs commentaires à ajouter, 

les flèches droites et gauches de la fenêtre de dialogue, déplaceront votre curseur d'action en 

action dans votre texte.

Pour accepter ou rejeter les modifications faites sur document, faire : sous le menu Édition 

-> Modification, sélectionnez Accepter ou rejeter. Voici la fenêtre qui s'ouvre :
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Less commentaires apparaîtront sous l'onglet  Description.

Voyons maintenant ce que cela donne lorsque vous recevez un texte qui a été modifié et que 

votre  collègue  a  enregistré  ses  modifications.  Ouvrez  le  document.  Si  les  modifications 

n'apparaissent  pas en couleur, c'est que vous n'avez pas spécifié  l'affichage, allez sous le 

menu  Édition -> Modification -> Affichage.

Le texte modifié par votre collègue apparaît en bleu. Son identité et la liste de ses actions 

apparaissent sous l'onglet Liste de la boite de dialogue de modification. L'action que vous êtes 

entrain de traiter apparaît en surbrillance tant dans le texte que dans la liste de la boite de 

dialogue. Une action traitée disparaît ensuite de la liste.

Note : Modifier les couleurs des actions et des auteurs

Vous pouvez modifier toutes les couleurs utilisées pour les modifications de vos documents. 

Pour cela faire : Outils -> Options -> Texte -> Modifications.
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Voilà une façon de personnaliser les modifications effectuées sur vos documents. 

Notez que vous pouvez également  déplacer les  marques  faites  dans la  marge à un autre 

endroit  (marge  de  droite,...).  La  Couleur  par  auteur  à  néanmoins  l'avantage  de  vous 

permettre de reconnaître les modifications faites par un tiers, puisque OpenOffice fera varier 

la couleur en fonction de l'auteur.

 II.12 - Protection du document

Il est possible de protéger un document afin qu'il ne soit accessible qu'avec un mot de passe.

Pour activer cette fonctionnalité,

•  Fichier -> Enregistrer sous…

•  Cocher la case "Enregistrer avec un mot de passe" au bas de la boîte de dialogue

Les fonctions de protection de OpenOffice.org s'étendent beaucoup plus loin que celle de

Microsoft Office.
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 II.13 - Insérer un Filigrane

Les filigranes sont des images que l'on place à l'arrière-plan d'un document. Cela peut être le 

logo de votre société, un texte, ou n'importe quel dessin que vous souhaitez mettre en arrière 

plan...

Nous allons d'abord procéder sur une page, puis sur toutes les pages, puis sur un paragraphe.

 Créer un filigrane sur une page

• Dans le menu Insertion, choisissez Images. A partir d'un fichier ou d'un scanner, 

cela n'a pas d'importance. Si  vous choisissez à partir  d'un fichier,  naviguez jusqu'à 

trouver votre fichier et cliquez sur Ouvrir.

• Votre image s'insère dans votre document telle qu'elle est. 

• Cliquez sur le menu déroulant du style et choisissez  Filigrane, votre image s'insère 

en filigrane.

• Pour que vous puissiez écrire sur cette image et qu'elle soit considérée comme un fond 

de page, faites un clic droit et choisissez  Image ou cliquez sur le bouton  Propriétés 

de la barre d'outils. La fenêtre suivante apparaît :
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• Dans la fenêtre qui s'ouvre, modifié l'Ancrage pour qu'il se fasse à la page et modifiez 

également la position Vertical pour que l'ancrage soit centré dans la page,

• Maintenant  cliquez sur l'onglet  Adaptation du texte, choisissez une adaptation au 

texte Continu et cochez la case A l'arrière plan.
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• Cliquez sur OK, vous pouvez maintenant entrer votre texte sur votre page.

 Sur plusieurs pages

Pour mettre votre filigrane sur plusieurs pages, vous devez l'inscrire dans votre format de 

page. Le mieux est donc d'enregistrer votre image en style filigrane et ensuite de l'inclure 

dans votre page en arrière-plan.

• Ouvrez le module Draw d'OpenOffice.org, et à partir du menu Insertion, insérez votre 

image.

• Vous  découvrez  la  même barre  d'outils  que  celle  affichée  ci-dessus,  donc  modifiez 

Standard dans le menu déroulant et optez pour Filigrane,

• Sans  déselectionner  votre  image (si  vous  l'avez  fait,  refaite  un  clic  dessus  pour  la 

sélectionner),  dans  le  menu  Fichier,  choisissez  Exporter.  Sous  types  de  fichier, 

choisissez bmp, jpg, png... le format que vous désirez. Et enregistrez-le.

• Revenez maintenant à votre document Writer,

• Sous Format -> Page, choisissez l'onglet Arrière-plan. Dans le menu déroulant Type, 

sélectionnez  Image. Puis cliquez sur le bouton Parcourir et naviguez jusqu'à trouver 

votre  image.  (Note  :  vous  pouvez  vous  constituer  ainsi  un  répertoire  uniquement 

réservé à vos filigranes). Sélectionnez-la et cliquez sur Ouvrir, vous revenez à la boite 

de dialogue de départ :
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Il ne vous reste plus qu'à régler la position et à appuyer sur OK. 

• Votre image est maintenant insérée sur toutes les pages, en filigrane.

Sur un paragraphe

Pour un paragraphe, vous procéderez de la même façon que pour la page, sauf que vous 

choisirez  Format ->  Paragraphe et  l'onglet  Arrière-plan.  Vous  pouvez  ainsi  mettre  un 

arrière-plan différent à tous vos paragraphe si vous le désirez.

 II.14 - Gestion des automatismes

OpenOffice.org  est  configuré  pour  exécuter  des  formatages  de  textes 

automatiquement  pendant  la  frappe.  Ces  automatismes  peuvent  être  amusants  ou 

franchement  gênants,  surtout  qu’ils  peuvent  intervenir  à  des  moments  où  vous  ne  les 

attendez pas. Vous avez deux solutions : soit les désactiver, soit apprendre à les domestiquer 

: faites les vôtres !

• Pour TOUS les (dés)activer, sélectionnez : ‘Format – AutoFormat – Pendant la saisie’ 

• Pour  n’en  (dés)activer  que  certains   ou  les  adapter  :  ‘Outils – 

AutoCorrection/AutoFormat’
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III - EQUIVALENCES MS WORD & OPENOFFICE.ORG WRITER

Menu Fichier :

Fichier -> Envoyer vers Fichier -> Envoyer

Fichier -> Mise en page... Format -> Page, onglet Page (voir plus bas)

Fichier -> Aperçu de la page web Affichage -> Mise en page en ligne

Fichier -> Enregistrer en tant que page web Fichier  ->  Envoyer  ->  Créer  Document 

HTML.

Menu Édition :

Édition -> Rechercher Édition -> Rechercher & Remplacer

Édition -> Remplacer Édition -> Rechercher & Remplacer.

Menu Insertion:

Insertion -> Saut... Insertion -> Saut manuel...

Insertion -> Numéros de page... Insertion -> Champ -> Numéro de page

Insertion -> Champ Insertion -> Champ -> Autre…

Insertion -> Note de pas de page Outils -> Note de bas de page

Insertion -> Tables et Index Insertion -> Index -> Index

Insertion -> Lien Hypertexte Insertion -> Hyperlien

Menu Format :

Format -> Police Format -> Caractères

Format -> Puces et numéros Format -> Numérotation & Puces

Format -> Bordure & trame Format -> Paragraphe, Onglet Bordure

Format -> Tabulations Format -> Paragraphe, Onglet Tabulations

Format -> Lettrine Format -> Paragraphe. Lettrines
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Format -> Orientation du texte Voir fonctionnalités (plus bas)

Format -> Modifier la casse Format -> Casse/Caractères

Format -> Arrière plan Format -> Paragraphe... - onglet Arrière-plan

            ou Format -> Page... - onglet Arrière-plan

Format -> Cadre Insertion -> Cadre

Format -> Mise en forme automatique Format -> Styliste

Menu Outils :

Outils -> Vérification de l'orthographe Outils -> Orthographe -> Vérification

Outils -> Langue Outils -> Options, Paramètres de linguistiques

Outils -> Statistiques Fichier -> Propriétés..., onglet Statistique

Outils -> Enveloppes et étiquettes Format -> Enveloppe

Outils -> Synthèse automatique Fichier -> Envoyer -> Créer une AutoSynthèse

Outils -> Correction automatique Outils -> Orthographe -> Vérification Automatique

Outils -> Suivi des modifications Édition -> Modifications

Outils -> Fusion de documents

Menu "Tableau" :

Insertion -> Tableau (AutoFormat… pour les formes automatiques).

IV - DOCUMENTATION

Pour toute information complémentaire veuillez consulter les sites suivants :

• Le site OpenOffice.org à l'adresse suivante :

http://fr.openoffice.org/Documentation/Index.html

et

http://fr.openoffice.org/faq-fr.html
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